NetSight
medium6.5

CVE-2025-27526

Apache InLong: JDBC Vulnerability For URLEncode and backspace bypass

Impact

Deserialization of Untrusted Data vulnerability in Apache InLong. This issue affects Apache InLong: from 1.13.0 through 2.1.0. This vulnerability which can lead to JDBC Vulnerability URLEncode and backspace bypass. Users are advised to upgrade to Apache InLong's 2.2.0 or cherry-pick [1] to solve it. [1]  https://github.com/apache/inlong/pull/11747

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:manager-pojo>= 1.13.0, < 2.2.02.2.0

Affected products

VendorProductAffected versions
ApacheInlong
from 1.13.0 before 2.2.0

Weakness classification

References