critical9.8
CVE-2025-27531
Apache InLong Deserialization of Untrusted Data Vulnerability
Impact
Deserialization of Untrusted Data vulnerability in Apache InLong. This issue affects Apache InLong: from 1.13.0 before 2.1.0, this issue would allow an authenticated attacker to read arbitrary files by double writing the param. Users are recommended to upgrade to version 2.1.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.inlong:inlong-manager | >= 1.13.0, < 2.1.0 | 2.1.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Inlong | from 1.13.0 before 2.1.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/r62lkqrr739wvcb60j6ql6q63rh4bxx5
- http://www.openwall.com/lists/oss-security/2025/02/28/2
- https://github.com/advisories/GHSA-62gc-8jr5-x9pm
- https://nvd.nist.gov/vuln/detail/CVE-2025-27531
- https://github.com/apache/inlong/issues/11585
- https://github.com/apache/inlong/pull/11586
- https://github.com/apache/inlong/commit/ebcd6d3230b73abdc41edb93619be2a26c9b8c97