high8.8
CVE-2025-27696
Apache Superset Allows Ownership Takeover
Impact
Improper Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions. This issue affects Apache Superset: through 4.1.1. Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | apache-superset | < 4.1.2 | 4.1.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Superset | before 4.1.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/k2od03bxnxs6vcp80sr03ywcxl194413
- http://www.openwall.com/lists/oss-security/2025/05/12/3
- https://github.com/advisories/GHSA-w6c7-j32f-rq8j
- https://nvd.nist.gov/vuln/detail/CVE-2025-27696
- https://github.com/apache/superset/commit/fc844d3dfdace890b32c00a507a959b81122b425