high7.3
CVE-2025-27821
Apache Hadoop HDFS Native Client has Out-of-bounds Write Vulnerability
Impact
Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client. This issue affects Apache Hadoop: from 3.2.0 before 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.hadoop:hadoop-hdfs-native-client | >= 3.2.0, < 3.4.2 | 3.4.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Hadoop | from 3.2.0 before 3.4.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/kwjhyyx0wl2z9b0mw0styjk0hhdbyplh
- http://www.openwall.com/lists/oss-security/2026/01/23/7
- https://github.com/advisories/GHSA-92cc-952p-v8rh
- https://nvd.nist.gov/vuln/detail/CVE-2025-27821
- https://github.com/apache/hadoop/pull/7481
- https://github.com/apache/hadoop/commit/2b32e46f666c7645f5d1e026be3982b99319ccb8
- https://issues.apache.org/jira/browse/HDFS-17754