medium5.6
CVE-2025-27867
Apache Felix HTTP Webconsole Plugin: XSS in HTTP Webconsole Plugin
Impact
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix HTTP Webconsole Plugin. This issue affects Apache Felix HTTP Webconsole Plugin: from Version 1.X through 1.2.0. Users are recommended to upgrade to version 1.2.2, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.felix:org.apache.felix.http.webconsoleplugin | < 1.2.2 | 1.2.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Felix Http Webconsole Plugin | from 1.0.0 before 1.2.2 |