medium4.8
CVE-2025-29790
Contao Vulnerable to Cross-Site Scripting (XSS) through SVG uploads
Impact
### Impact Users can upload SVG files with malicious code, which is then executed in the back end and/or front end. ### Patches Update to Contao 4.13.54, 5.3.30 or 5.5.6. ### Workarounds Remove `svg,svgz` from the allowed upload file types in the system settings and from `contao.editable_files` in the `config.yaml`. ### References https://contao.org/en/security-advisories/cross-site-scripting-through-svg-uploads ### For more information If you have any questions or comments about this advisory, open an issue in [contao/contao](https://github.com/contao/contao/issues/new/choose).
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | contao/core-bundle | >= 4.0.0, < 4.13.54 | 4.13.54 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Contao | Contao | from 4.0.0 before 4.13.53 from 5.0.0 before 5.3.30 from 5.4.0 before 5.5.6 |