NetSight
critical9.1Public exploit code

CVE-2025-29927

Authorization Bypass in Next.js Middleware

Public exploit code

Working exploit or proof of concept code has been published for this vulnerability. Treat unpatched systems as at risk.

Impact

# Impact It is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. # Patches * For Next.js 15.x, this issue is fixed in `15.2.3` * For Next.js 14.x, this issue is fixed in `14.2.25` * For Next.js 13.x, this issue is fixed in 13.5.9 * For Next.js 12.x, this issue is fixed in 12.3.5 * For Next.js 11.x, consult the below workaround. _Note: Next.js deployments hosted on Vercel are automatically protected against this vulnerability._ # Workaround If patching to a safe version is infeasible, we recommend that you prevent external user requests which contain the `x-middleware-subrequest` header from reaching your Next.js application. ## Credits - Allam Rachid (zhero;) - Allam Yasser (inzo_)

Affected packages

EcosystemPackageAffectedFixed in
npmnext>= 13.0.0, < 13.5.913.5.9

Affected products

VendorProductAffected versions
VercelNext.Js
from 11.1.4 before 12.3.5
from 13.0.0 before 13.5.9
from 14.0.0 before 14.2.25
from 15.0.0 before 15.2.3

Weakness classification

References