high7.3
CVE-2025-30001
Apache StreamPark contains an Incorrect Execution-Assigned Permissions vulnerability
Impact
Incorrect Execution-Assigned Permissions vulnerability in Apache StreamPark. This issue affects Apache StreamPark: from 2.1.4 before 2.1.6. Users are recommended to upgrade to version 2.1.6, which fixes the issue. Version 2.1.6 has yet to be published in the Maven registry.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.streampark:streampark | <= 2.1.5 | none recorded |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Streampark | from 2.1.4 before 2.1.6 |