NetSight
high7.2

CVE-2025-30067

Apache Kylin Code Injection via JDBC Configuration Alteration

Impact

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.1. Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.kylin:kylin>= 4.0.0, < 5.0.25.0.2

Affected products

VendorProductAffected versions
ApacheKylin
from 4.0.0 before 5.0.2

Weakness classification

References