NetSight
medium5.9

CVE-2025-30081

Clickstorm SEO Allows Cross-Site Scripting (XSS)

Impact

A cross-site scripting (XSS) vulnerability has been discovered in the Clickstorm SEO extension. This vulnerabily is exploitable by a logged in backend user utilizing the TYPO3 backend user interface. This user can create output in the HTML context by exploiting improperly encoded user input. Updates 6.7.0, 7.4.0, 8.3.0 and 9.2.0 are available for download.

Affected packages

EcosystemPackageAffectedFixed in
composerclickstorm/cs-seo>= 9.0.0, < 9.2.09.2.0
composerclickstorm/cs-seo>= 8.0.0, < 8.3.08.3.0
composerclickstorm/cs-seo>= 7.0.0, < 7.4.07.4.0
composerclickstorm/cs-seo>= 6.0.0, < 6.7.06.7.0

Weakness classification

References