high7.5
CVE-2025-30151
Shopware allows Denial Of Service via password length
Impact
### Impact It's possible to pass long passwords that leads to Denial Of Service via forms in Storefront forms or Store-API. ### Patches Update to Shopware 6.6.10.3 or 6.5.8.17 ### Workarounds For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | shopware/core | >= 6.6.0.0, < 6.6.10.3 | 6.6.10.3 |
| composer | shopware/platform | >= 6.6.0.0, < 6.6.10.3 | 6.6.10.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Shopware | Shopware | before 6.5.8.17 from 6.6.0.0 before 6.6.10.3 Version 6.7.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/shopware/shopware/security/advisories/GHSA-cgfj-hj93-rmh2
- https://github.com/advisories/GHSA-cgfj-hj93-rmh2
- https://github.com/shopware/shopware/releases/tag/v6.5.8.17
- https://github.com/shopware/shopware/releases/tag/v6.6.10.3
- https://github.com/shopware/shopware/releases/tag/v6.7.0.0-rc2
- https://nvd.nist.gov/vuln/detail/CVE-2025-30151