NetSight
critical9.8

CVE-2025-31651

Apache Tomcat Rewrite rule bypass

Impact

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. For a subset of unlikely rewrite rule configurations, it was possible for a specially crafted request to bypass some rewrite rules. If those rewrite rules effectively enforced security constraints, those constraints could be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.5, from 10.1.0-M1 through 10.1.39, from 9.0.0.M1 through 9.0.102. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6, which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat-catalina>= 9.0.76, <= 9.0.1029.0.104
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 9.0.76, <= 9.0.1029.0.104

Affected products

VendorProductAffected versions
ApacheTomcat
from 9.0.0 before 9.0.104
from 10.1.0 before 10.1.40
from 11.0.0 before 11.0.6

Weakness classification

References