NetSight
medium4.5

CVE-2025-4166

Hashicorp Vault Community vulnerable to Generation of Error Message Containing Sensitive Information

Impact

Vault Community and Vault Enterprise Key/Value (kv) Version 2 plugin may unintentionally expose sensitive information in server and audit logs when users submit malformed payloads during secret creation or update operations via the Vault REST API. This vulnerability, identified as CVE-2025-4166, is fixed in Vault Community 1.19.3 and Vault Enterprise 1.19.3, 1.18.9, 1.17.16, 1.16.20.

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/hashicorp/vault>= 0.3.0, < 1.19.31.19.3

Affected products

VendorProductAffected versions
HashicorpVault
from 0.3.0 before 1.16.20
from 0.3.0 before 1.19.3
from 1.17.0 before 1.17.16
from 1.18.0 before 1.18.9
from 1.19.0 before 1.19.3
OpenbaoOpenbao
before 2.2.2

Weakness classification

References