medium4.9
CVE-2025-46344
Auth0 NextJS SDK v4 Missing Session Invalidation
Impact
### Overview Auth0 NextJS `v4.0.1` to `v4.5.0` does not invoke `.setExpirationTime` when generating a JWE token for the session. As a result, the JWE does not contain an internal expiration claim. While the session cookie may expire or be cleared, the JWE remains valid. ### Am I Affected? You are affected if you are using Auth0 NextJS SDK v4. ### Fix Upgrade to `v4.5.1`.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | @auth0/nextjs-auth0 | >= 4.0.1, < 4.5.1 | 4.5.1 |
Affected products
| Product | Affected versions |
|---|---|
| Next.Js Applications. Versions Starting From 4.0.1 And | before 4.5.1 |
Versions were read from the advisory text. No structured product data has been published for this record yet.
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/auth0/nextjs-auth0/commit/a4f061aed02ffa132feca8adfbd11704df17e1c3
- https://github.com/auth0/nextjs-auth0/releases/tag/v4.5.1
- https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-pjr6-jx7r-j4r6
- https://github.com/advisories/GHSA-pjr6-jx7r-j4r6
- https://nvd.nist.gov/vuln/detail/CVE-2025-46344