medium6.5
CVE-2025-46548
Pekko Management may not properly apply authenticator when Basic Authentication is enabled
Impact
If you enable Basic Authentication in Pekko Management using the Java DSL, the authenticator may not be properly applied. Users that rely on authentication instead of making sure the Management API ports are only available to trusted users are recommended to upgrade to version 1.1.1, which fixes this issue. Akka was affected by the same issue and has released the fix in version 1.6.1.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.pekko:pekko-management_2.12 | < 1.1.1 | 1.1.1 |
| maven | com.lightbend.akka.management:akka-management_2.13 | < 1.6.1 | 1.6.1 |
| maven | org.apache.pekko:pekko-management_2.13 | < 1.1.1 | 1.1.1 |
| maven | org.apache.pekko:pekko-management_3 | < 1.1.1 | 1.1.1 |
| maven | com.lightbend.akka.management:akka-management_2.12 | < 1.6.1 | 1.6.1 |
| maven | com.lightbend.akka.management:akka-management_3 | < 1.6.1 | 1.6.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Pekko Management | from 1.0.0 through 1.1.1 |
| Akka | Akka Management | before 1.6.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/akka/akka-management/pull/1385
- https://github.com/apache/pekko-management/pull/418
- https://lists.apache.org/thread/tnd84hj9w0ggjcft6cp12q67d5jzhp66
- http://www.openwall.com/lists/oss-security/2025/06/03/7
- https://github.com/advisories/GHSA-9qvj-rpj8-v5c8
- https://nvd.nist.gov/vuln/detail/CVE-2025-46548