NetSight
high7.3

CVE-2025-46701

Apache Tomcat - CGI security constraint bypass

Impact

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat-catalina>= 9.0.0.M1, < 9.0.1059.0.105
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 9.0.0.M1, < 9.0.1059.0.105

Affected products

VendorProductAffected versions
ApacheTomcat
from 9.0.0 before 9.0.105
from 10.1.0 before 10.1.41
from 11.0.0 before 11.0.7

Weakness classification

References