NetSight
high7.3

CVE-2025-46731

Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI

Impact

Craft CMS contains a potential remote code execution vulnerability via Twig SSTI. You must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production Note: This is a follow-up to https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv Users should update to the patched versions (4.14.13 and 5.6.15) to mitigate the issue. ### References https://github.com/craftcms/cms/pull/17026

Affected packages

EcosystemPackageAffectedFixed in
composercraftcms/cms>= 4.0.0-RC1, <= 4.14.124.14.13

Affected products

VendorProductAffected versions
CraftcmsCraft Cms
from 4.1.0 before 4.14.13
from 5.1.0 before 5.6.15
Versions 4.0.0, 5.0.0

Weakness classification

References