NetSight
high8.8

CVE-2025-47410

Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system

Impact

Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user. This issue affects Apache Geode: versions 1.10 through 1.15.1 Users are recommended to upgrade to version 1.15.2, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.geode:geode-web>= 1.10.0, < 1.15.21.15.2

Affected products

VendorProductAffected versions
ApacheGeode
from 1.10.0 before 1.15.2

Weakness classification

References