high8.1
CVE-2025-47411
Apache StreamPipes has Improper Privilege Management issue
Impact
A user with a legitimate non-administrator account can exploit a vulnerability in the user ID creation mechanism in Apache StreamPipes that allows them to swap the username of an existing user with that of an administrator. This vulnerability allows an attacker to gain administrative control over the application by manipulating JWT tokens, which can lead to data tampering, unauthorized access and other security issues. This issue affects Apache StreamPipes: through 0.97.0. Users are recommended to upgrade to version 0.98.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.streampipes:streampipes-parent | >= 0.69.0, < 0.98.0 | 0.98.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Streampipes | from 0.69.0 before 0.98.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/lngko4ht2ok3o0rk9h0clgm4kb0lmt36
- http://www.openwall.com/lists/oss-security/2025/12/29/14
- https://github.com/advisories/GHSA-5r2g-vphf-m5xc
- https://nvd.nist.gov/vuln/detail/CVE-2025-47411
- https://github.com/apache/streampipes/releases/tag/release%2F0.98.0