CVE-2025-4760
WSO2 carbon-apimgt affected by an authenticated stored cross-site scripting (XSS) vulnerability
Impact
An authenticated stored Cross-Site Scripting (XSS) vulnerability exists in WSO2 API Manager components (`carbon-apimgt`) due to insufficient validation of user-supplied input during API document upload in the Publisher portal. A user with publisher privileges can upload a crafted API document whose contents are later rendered in the UI for other users, leading to attacker-controlled script execution. Likely outcomes include redirection to malicious sites, unauthorized UI modifications, or exfiltration of data accessible to the browser; session hijacking is mitigated by the use of `HttpOnly` session cookies. To remediate, update to version 9.31.117 or above.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.api | < 9.31.117 | 9.31.117 |
| maven | org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.publisher.v1 | < 9.31.117 | 9.31.117 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Wso2 | Api Control Plane | Version 4.5.0 |
| Wso2 | Api Manager | Versions 3.2.0, 3.2.1, 4.1.0, 4.2.0, 4.3.0, 4.4.0 |
| Wso2 | Traffic Manager | Version 4.5.0 |
| Wso2 | Universal Gateway | Version 4.5.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2025/WSO2-2025-4104/
- https://github.com/advisories/GHSA-cmjc-qp7j-xgwr
- https://nvd.nist.gov/vuln/detail/CVE-2025-4760
- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2025/WSO2-2025-4104
- https://github.com/wso2/carbon-apimgt/pull/13099
- https://github.com/wso2/carbon-apimgt/commit/1b3496c072ec68aaaf726996e2caa76f07c1adca
- https://mvnrepository.com/artifact/org.wso2.carbon.apimgt/org.wso2.carbon.apimgt.api/9.31.117