NetSight
high7.5

CVE-2025-47944

Multer vulnerable to Denial of Service from maliciously crafted requests

Impact

### Impact A vulnerability in Multer versions >=1.4.4-lts.1 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. ### Patches Users should upgrade to `2.0.0` ### Workarounds None ### References - https://github.com/expressjs/multer/issues/1176 - https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665

Affected packages

EcosystemPackageAffectedFixed in
npmmulter>= 1.4.4-lts.1, < 2.0.02.0.0

Weakness classification

References