high7.5
CVE-2025-48392
Apache IoTDB: DoS Vulnerability
Impact
A vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.3.3 through 1.3.4, from 2.0.1-beta through 2.0.4. Users are recommended to upgrade to version 2.0.5, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.iotdb:iotdb-core | >= 1.3.3, < 2.0.5 | 2.0.5 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Iotdb | from 1.3.3 through 1.3.4 from 2.0.1 before 2.0.5 |