NetSight
high7.1

CVE-2025-48912

Apache Superset: Improper authorization bypass on row level security via SQL Injection

Impact

An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-superset< 4.1.24.1.2

Affected products

VendorProductAffected versions
ApacheSuperset
before 4.1.2

Weakness classification

References