medium6.5
CVE-2025-48924
Apache Commons Lang is vulnerable to Uncontrolled Recursion when processing long inputs
Impact
Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.commons:commons-lang3 | >= 3.0, < 3.18.0 | 3.18.0 |
| maven | commons-lang:commons-lang | >= 2.0, <= 2.6 | none recorded |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Commons Lang | from 2.0 before 2.6 from 3.0 before 3.18.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/bgv0lpswokgol11tloxnjfzdl7yrc1g1
- http://www.openwall.com/lists/oss-security/2025/07/11/1
- https://lists.debian.org/debian-lts-announce/2025/08/msg00000.html
- https://lists.debian.org/debian-lts-announce/2025/08/msg00026.html
- https://lists.debian.org/debian-lts-announce/2025/09/msg00032.html
- https://lists.debian.org/debian-lts-announce/2025/09/msg00036.html
- https://github.com/advisories/GHSA-j288-q9x7-2f5v
- https://nvd.nist.gov/vuln/detail/CVE-2025-48924
- https://github.com/apache/commons-lang/commit/b424803abdb2bec818e4fbcb251ce031c22aca53