high6.5
CVE-2025-48977
Apache Ignite REST API Has a Relative Path Traversal Vulnerability
Impact
Relative Path Traversal vulnerability in Apache Ignite REST API. Authenticated REST API users can read any file on the server with "cmd=log" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0. Users are recommended to upgrade to version 2.18.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.ignite:ignite-core | >= 2.0.0, < 2.18.0 | 2.18.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Ignite | from 2.0.0 before 2.18.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-v45h-mqf4-6939
- https://nvd.nist.gov/vuln/detail/CVE-2025-48977
- https://lists.apache.org/thread/hgct6918sowd8l58yjohryhpxx81t4n1
- http://www.openwall.com/lists/oss-security/2026/05/28/3
- https://github.com/apache/ignite/commit/5c42c7a303937844179ad470edb35c1ad1cee6ab