NetSight
high7.5

CVE-2025-48989

Apache Tomcat Improper Resource Shutdown or Release vulnerability

Impact

Improper Resource Shutdown or Release vulnerability in Apache Tomcat made Tomcat vulnerable to the made you reset attack. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.9, from 10.1.0-M1 through 10.1.43 and from 9.0.0.M1 through 9.0.107. Older, EOL versions may also be affected. Users are recommended to upgrade to one of versions 11.0.10, 10.1.44 or 9.0.108 which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat-coyote>= 11.0.0-M1, < 11.0.1011.0.10
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 11.0.0-M1, < 11.0.1011.0.10

Affected products

VendorProductAffected versions
ApacheTomcat
from 9.0.1 before 9.0.108
from 10.0.0 before 10.1.44
from 11.0.0 before 11.0.10
Version 9.0.0

Weakness classification

References