NetSight
high8.7

CVE-2025-48997

Multer vulnerable to Denial of Service via unhandled exception

Impact

### Impact A vulnerability in Multer versions >=1.4.4-lts.1, <2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. ### Patches Users should upgrade to `2.0.1` ### Workarounds None ### References https://github.com/expressjs/multer/commit/35a3272b611945155e046dd5cef11088587635e9 https://github.com/expressjs/multer/issues/1233 https://github.com/expressjs/multer/pull/1256

Affected packages

EcosystemPackageAffectedFixed in
npmmulter>= 1.4.4-lts.1, < 2.0.12.0.1

Weakness classification

References