low3.7
CVE-2025-49005
Next.js has a Cache poisoning vulnerability due to omission of the Vary header
Impact
### Summary A cache poisoning issue in **Next.js App Router >=15.3.0 and < 15.3.3** may have allowed RSC payloads to be cached and served in place of HTML, under specific conditions involving middleware and redirects. This issue has been fixed in **Next.js 15.3.3**. Users on affected versions should **upgrade immediately** and **redeploy** to ensure proper caching behavior. More details: [CVE-2025-49005](https://vercel.com/changelog/cve-2025-49005)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | next | >= 15.3.0, < 15.3.3 | 15.3.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Vercel | Next.Js | from 15.3.0 before 15.3.3 |
| Vercel | Vercel | from 41.4.1 before 42.2.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/vercel/next.js/commit/ec202eccf05820b60c6126d6411fe16766ecc066
- https://github.com/vercel/next.js/issues/79346
- https://github.com/vercel/next.js/releases/tag/v15.3.3
- https://github.com/vercel/next.js/security/advisories/GHSA-r2fc-ccr8-96c4
- https://vercel.com/changelog/cve-2025-49005
- https://github.com/advisories/GHSA-r2fc-ccr8-96c4
- https://github.com/vercel/next.js/pull/79939
- https://nvd.nist.gov/vuln/detail/CVE-2025-49005