NetSight
high8.4

CVE-2025-49124

Apache Tomcat installer for Windows has an untrusted search path vulnerability

Impact

Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 11.0.0-M1, < 11.0.811.0.8
mavenorg.apache.tomcat:tomcat>= 11.0.0-M1, < 11.0.811.0.8
mavenorg.apache.tomcat:tomcat-catalina>= 11.0.0-M1, < 11.0.811.0.8

Affected products

VendorProductAffected versions
ApacheTomcat
from 9.0.23 before 9.0.106
from 10.1.0 before 10.1.42
from 11.0.0 before 11.0.8

Weakness classification

References