medium5.3
CVE-2025-49147
Umbraco CMS disclosure of configured password requirements
Impact
### Impact Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password. The vulnerability can be found in the supported Umbraco versions 10 and 13. It was not exposed in Umbraco 7 or 8, nor in 14 or higher versions. ### Patches Patched in 10.8.11 and 13.9.2
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| nuget | Umbraco.Cms | >= 10.0.0, < 10.8.11 | 10.8.11 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Umbraco | Umbraco Cms | from 10.0.0 before 10.8.11 from 13.0.0 before 13.9.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/umbraco/Umbraco-CMS/commit/b4144564c836ec6929111ce2a12eb1f67b42d61e
- https://github.com/umbraco/Umbraco-CMS/commit/d8f68d2c40f8e158bd81d469f25ef3a4e1d86c4c
- https://github.com/umbraco/Umbraco-CMS/security/advisories/GHSA-pgvc-6h2p-q4f6
- https://github.com/advisories/GHSA-pgvc-6h2p-q4f6
- https://nvd.nist.gov/vuln/detail/CVE-2025-49147