NetSight
critical9.4

CVE-2025-49596

MCP Inspector proxy server lacks authentication between the Inspector client and proxy

Impact

Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities. Credit: Rémy Marot <bughunters@tenable.com>

Affected packages

EcosystemPackageAffectedFixed in
npm@modelcontextprotocol/inspector< 0.14.10.14.1

Weakness classification

References