NetSight
medium5.3

CVE-2025-5174

pypickle unsafe deserialization vulnerability

Impact

A vulnerability was found in erdogant pypickle up to 1.1.5 and classified as problematic. Affected by this issue is the function load of the file pypickle/pypickle.py. The manipulation leads to deserialization. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

Affected packages

EcosystemPackageAffectedFixed in
pippypickle< 2.0.02.0.0

Affected products

VendorProductAffected versions
ErdogantPypickle
before 2.0.0

Weakness classification

References