NetSight
medium5.3

CVE-2025-5175

pypickle Incorrect Privilege Assignment vulnerability

Impact

A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

Affected packages

EcosystemPackageAffectedFixed in
pippypickle< 2.0.02.0.0

Affected products

VendorProductAffected versions
ErdogantPypickle
before 2.0.0

Weakness classification

References