high7.5
CVE-2025-52434
Apache Tomcat is vulnerable to resource exhaustion when using the APR/Native connector
Impact
Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in Apache Tomcat when using the APR/Native connector. This was particularly noticeable with client initiated closes of HTTP/2 connections. This issue affects Apache Tomcat: from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 9.0.107, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.tomcat:tomcat-coyote | >= 9.0.0.M1, < 9.0.107 | 9.0.107 |
| maven | org.apache.tomcat.embed:tomcat-embed-core | >= 9.0.0.M1, < 9.0.107 | 9.0.107 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Tomcat | from 9.0.0 before 9.0.107 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/gxgh65004f25y8519coth6w7vchww030
- http://www.openwall.com/lists/oss-security/2025/07/10/11
- https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html
- https://github.com/advisories/GHSA-4j3c-42xv-3f84
- https://nvd.nist.gov/vuln/detail/CVE-2025-52434
- https://github.com/apache/tomcat/commit/8a83c3c42d20762782678932c14005cd3397a018