NetSight
medium6.9

CVE-2025-52662

Nuxt DevTools vulnerable to cross-site scripting (XSS)

Impact

A vulnerability in Nuxt DevTools has been fixed in version **2.6.4***. This issue may have allowed Nuxt auth token extraction via XSS under certain configurations. All users are encouraged to upgrade.

Affected packages

EcosystemPackageAffectedFixed in
npm@nuxt/devtools< 2.6.42.6.4

Affected products

VendorProductAffected versions
NuxtDevtools
before 2.6.4

Weakness classification

References