NetSight
high7.5

CVE-2025-53506

Apache Tomcat Coyote vulnerable to Denial of Service via excessive HTTP/2 streams

Impact

Uncontrolled Resource Consumption vulnerability in Apache Tomcat if an HTTP/2 client did not acknowledge the initial settings frame that reduces the maximum permitted concurrent streams. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat-coyote>= 11.0.0-M1, < 11.0.911.0.9
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 8.5.0, <= 8.5.100none recorded

Affected products

VendorProductAffected versions
ApacheTomcat
from 9.0.0 through 9.0.106
from 10.1.0 through 10.1.42
from 11.0.0 through 11.0.8

Weakness classification

References