high8.8
CVE-2025-53689
Apache Jackrabbit vulnerable to blind XXE attack due to insecure document build
Impact
Blind XXE vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.jackrabbit:jackrabbit-spi-commons | >= 2.20.0, < 2.20.17 | 2.20.17 |
| maven | org.apache.jackrabbit:jackrabbit-core | >= 2.23.0-beta, < 2.23.2-beta | 2.23.2-beta |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Jackrabbit | from 2.20.0 before 2.20.17 Versions 2.22.0, 2.23.0, 2.23.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/5pf9n76ny13pzzk765og2h3gxdxw7p24
- http://www.openwall.com/lists/oss-security/2025/07/14/1
- https://github.com/advisories/GHSA-44c3-38h8-9fh9
- https://nvd.nist.gov/vuln/detail/CVE-2025-53689
- https://github.com/apache/jackrabbit/pull/263/commits/02786c0a01838580252bdab79bfa54026c30294e