medium6.1
CVE-2025-54057
Apache SkyWalking has a stored XSS vulnerability
Impact
There is an Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache SkyWalking. This issue affects Apache SkyWalking versions <= 10.2.0. Users are recommended to upgrade to version 10.3.0, which fixes the issue. Version 10.3.0 has not been uploaded to the Maven registry at time of publish, please see [release notes](https://github.com/apache/skywalking/releases/tag/v10.3.0) for download instructions.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.skywalking:apm-webapp | <= 10.1.0 | none recorded |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Skywalking | before 10.3.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/sl2x2tx8y007x0mo746yddx2lvnv9tcr
- http://www.openwall.com/lists/oss-security/2025/11/27/1
- http://www.openwall.com/lists/oss-security/2026/04/13/3
- https://github.com/advisories/GHSA-v6x2-4q87-rf82
- https://nvd.nist.gov/vuln/detail/CVE-2025-54057