NetSight
medium6.5

CVE-2025-5472

LlamaIndex vulnerable to DoS attack through uncontrolled recursive JSON parsing

Impact

The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.

Affected packages

EcosystemPackageAffectedFixed in
pipllama-index-core< 0.12.380.12.38

Affected products

VendorProductAffected versions
LlamaindexLlamaindex
from 0.12.28 before 0.12.38

Weakness classification

References