NetSight
medium6.5

CVE-2025-55668

Apache Tomcat Session Fixation vulnerability

Impact

Session Fixation vulnerability in Apache Tomcat via rewrite valve. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat-catalina>= 11.0.0-M1, < 11.0.811.0.8
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 11.0.0-M1, < 11.0.811.0.8

Affected products

VendorProductAffected versions
ApacheTomcat
from 9.0.1 before 9.0.106
from 10.0.0 before 10.1.42
from 11.0.0 before 11.0.8
Version 9.0.0

Weakness classification

References