NetSight
medium5.3

CVE-2025-55675

Apache Superset allows authenticated users to discover metadata about datasources they don't have permission to access

Impact

Apache Superset contains an improper access control vulnerability in its /explore endpoint. A missing authorization check allows an authenticated user to discover metadata about datasources they do not have permission to access. By iterating through the datasource_id in the URL, an attacker can enumerate and confirm the existence and names of protected datasources, leading to sensitive information disclosure. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-superset< 5.0.05.0.0

Affected products

VendorProductAffected versions
ApacheSuperset
before 5.0.0

Weakness classification

References