CVE-2025-55752
Apache Tomcat Vulnerable to Relative Path Traversal
Impact
The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.0.M11 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.tomcat:tomcat | >= 11.0.0-M1, < 11.0.11 | 11.0.11 |
| maven | org.apache.tomcat:tomcat-catalina | >= 11.0.0-M1, < 11.0.11 | 11.0.11 |
| maven | org.apache.tomcat.embed:tomcat-embed-core | >= 11.0.0-M1, < 11.0.11 | 11.0.11 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Tomcat | from 8.5.6 through 8.5.100 from 9.0.1 before 9.0.109 from 10.0.0 before 10.0.27 from 10.1.0 before 10.1.45 from 11.0.0 before 11.0.11 Version 9.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/n05kjcwyj1s45ovs8ll1qrrojhfb1tog
- http://www.openwall.com/lists/oss-security/2025/10/27/4
- https://www.vicarius.io/vsociety/posts/cve-2025-55752-detect-apache-tomcat-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2025-55752-mitigate-apache-tomcat-vulnerability
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
- https://github.com/advisories/GHSA-wmwf-9ccg-fff5
- https://nvd.nist.gov/vuln/detail/CVE-2025-55752
- https://github.com/apache/tomcat/commit/130d36d8492ef9e4eb22952c17c92423cb35fd06
- https://github.com/apache/tomcat/commit/b5042622b8b78340ae65403c55dcb9c7416924df
- https://github.com/apache/tomcat/commit/fec06c610ed7466b401e29cc567a58aee5ed826a
- https://tomcat.apache.org/security-10.html#Fixed_in_Apache_Tomcat_10.1.45
- https://tomcat.apache.org/security-11.html#Fixed_in_Apache_Tomcat_11.0.11
- https://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.109