medium4.3
CVE-2025-57758
Contao applies improper access control in the back end voters
Impact
### Impact The table access voter in the back end doesn't check if a user is allowed to access the corresponding module. ### Patches Update to Contao 5.3.38 or 5.6.1. ### Workarounds Do not rely solely on the voter and additionally check `USER_CAN_ACCESS_MODULE`. ### For more information If you have any questions or comments about this advisory, open an issue in [contao/contao](https://github.com/contao/contao/issues/new/choose).
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | contao/core-bundle | >= 5.0.0, < 5.3.38 | 5.3.38 |
| composer | contao/contao | >= 5.0.0, < 5.3.38 | 5.3.38 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Contao | Contao | from 5.3.0 before 5.3.38 from 5.4.0 before 5.6.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://contao.org/en/security-advisories/improper-access-control-in-the-back-end-voters
- https://github.com/contao/contao/commit/3f05c603e1c94d34819f837f060df5d66447d0d7
- https://github.com/contao/contao/security/advisories/GHSA-7m47-r75r-cx8v
- https://github.com/advisories/GHSA-7m47-r75r-cx8v
- https://nvd.nist.gov/vuln/detail/CVE-2025-57758