high7.2
CVE-2025-57811
Craft CMS Potential Remote Code Execution via Twig SSTI
Impact
Note that users must have administrator access to the Craft Control Panel, and [allowAdminChanges](https://craftcms.com/docs/5.x/reference/config/general.html#allowadminchanges) must be enabled for this to work, which is against Craft CMS' recommendations for any non-dev environment. https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production Note: This is a follow-up to [GHSA-f3cw-hg6r-chfv](https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv) Users should update to the patched versions (4.16.6 and 5.8.7) to mitigate the issue. Resources: https://github.com/craftcms/cms/pull/17612
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | craftcms/cms | >= 4.0.0-RC1, <= 4.16.5 | 4.16.6 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Craftcms | Craft Cms | from 4.1.0 before 4.16.6 from 5.1.0 before 5.8.7 Versions 4.0.0, 5.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/craftcms/cms/commit/e77f8a287dcdda41f1724f525d03542f18566cbc
- https://github.com/craftcms/cms/pull/17612
- https://github.com/craftcms/cms/security/advisories/GHSA-crcq-738g-pqvc
- https://github.com/advisories/GHSA-crcq-738g-pqvc
- https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv
- https://nvd.nist.gov/vuln/detail/CVE-2025-57811