NetSight
critical9.1

CVE-2025-58068

Eventlet affected by HTTP request smuggling in unparsed trailers

Impact

### Impact The Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to: - Bypass front-end security controls - Launch targeted attacks against active site users - Poison web caches ### Patches Problem has been patched in eventlet 0.40.3. The patch just drops trailers. If a backend behind eventlet.wsgi proxy requires trailers, then this patch BREAKS your setup. ### Workarounds Do not use eventlet.wsgi facing untrusted clients. ### References - Patch https://github.com/eventlet/eventlet/pull/1062 - This issue is similar to https://github.com/advisories/GHSA-9548-qrrj-x5pj

Affected packages

EcosystemPackageAffectedFixed in
pipeventlet< 0.40.30.40.3

Affected products

VendorProductAffected versions
EventletEventlet
before 0.40.3

Weakness classification

References