NetSight
low3.1

CVE-2025-5889

brace-expansion Regular Expression Denial of Service vulnerability

Impact

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is `a5b98a4f30d7813266b221435e1eaaf25a1b0ac5`. It is recommended to upgrade the affected component.

Affected packages

EcosystemPackageAffectedFixed in
npmbrace-expansion>= 2.0.0, <= 2.0.12.0.2

Affected products

ProductAffected versions
Juliangruber Brace-Expansion
before 1.1.11

Versions were read from the advisory text. No structured product data has been published for this record yet.

Weakness classification

References