critical9.8
CVE-2025-59059
Apache Ranger has a Code Injection vulnerability
Impact
Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.ranger:ranger-plugins-common | < 2.8.0 | 2.8.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Ranger | before 2.8.0 |