medium5.3
CVE-2025-59060
Apache Ranger Vulnerable to Improper Validation of Certificate with Host Mismatch
Impact
Hostname verification bypass issue in Apache Ranger NiFiRegistryClient/NiFiClient is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.ranger:ranger-nifi-registry-plugin | < 2.8.0 | 2.8.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Ranger | before 2.8.0 |