NetSight
medium6.5

CVE-2025-59328

Apache Fory Deserialization of Untrusted Data vulnerability

Impact

A vulnerability in Apache Fory allows a remote attacker to cause a Denial of Service (DoS). The issue stems from the insecure deserialization of untrusted data. An attacker can supply a large, specially crafted data payload that, when processed, consumes an excessive amount of CPU resources during the deserialization process. This leads to CPU exhaustion, rendering the application or system using the Apache Fory library unresponsive and unavailable to legitimate users. Users of Apache Fory are strongly advised to upgrade to version 0.12.2 or later to mitigate this vulnerability. Developers of libraries and applications that depend on Apache Fory should update their dependency requirements to Apache Fory 0.12.2 or later and release new versions of their software.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.fory:fory-core< 0.12.20.12.2

Affected products

VendorProductAffected versions
ApacheFory
from 0.5.0 before 0.12.2

Weakness classification

References