NetSight
medium6.3

CVE-2025-60012

Apache Livy: Restrict file access

Impact

Malicious configuration can lead to unauthorized file access in Apache Livy. This issue affects Apache Livy 0.7.0 and 0.8.0 when connecting to Apache Spark 3.1 or later. A request that includes a Spark configuration value supported from Apache Spark version 3.1 can lead to users gaining access to files they do not have permissions to. For the vulnerability to be exploitable, the user needs to have access to Apache Livy's REST or JDBC interface and be able to send requests with arbitrary Spark configuration values. Users are recommended to upgrade to version 0.9.0 or later, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.livy:livy-server>= 0.7.0-incubating, < 0.9.0-incubating0.9.0-incubating

Affected products

VendorProductAffected versions
ApacheLivy
from 0.7.0 before 0.9.0

Weakness classification

References